Camera 1 not detected

StereoPi hardware discussion
Post Reply
chansek
Posts: 1
Joined: Wed Jan 22, 2020 4:43 am

Camera 1 not detected

Post by chansek » Wed Jan 22, 2020 4:56 am

I recently purchased the StereoPi for my projects. Unfortunately, I have not been able to get this working. I'm unable to get the 2nd camera to be detected.

I have done the following:
1. Installed the image with raspbian stretch & opencv from stereopi. vcgencmd get_camera says 2 cameras are supported but only one detected and its always camera 1. raspistill -cs 0 works, but raspistill -cs 1 outputs the following.

mmal: Cannot read camera info, keeping the defaults for OV5647
mmal: Could not select camera : error 3
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

2. I tried with a fresh raspbian image via noobs and I get the same error as above.
3. Swapped the cameras and still the same. Bought new cameras and still the same. All cameras used are Raspberry Camera Module v2
4. I tried to blow into the connector to remove dust or other impurities and it does not change the outcome.

AFAIK I have followed pretty much everything said in the forums to ensure that my cameras are not defective or that my installation was not proper. I have been using the dt-blob.bin from stereopi and copied them into the boot folder.

Is there anything I might have missed? My conclusion at the moment is that the board is defective. Can you help, please?

User avatar
Realizator
Site Admin
Posts: 392
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Camera 1 not detected

Post by Realizator » Wed Jan 22, 2020 7:24 am

Hi Chansec,
As I understand you've tried all possible troubleshooting approaches, so no need to add some more tests. I've wrote you direct email (to the email address you used for registering on this forum) to discuss replacement details. Please answer.
Eugene a.k.a. Realizator

Post Reply