7'' waveshare lcd hat

Other hardware discussion
Post Reply
tokanawa
Posts: 1
Joined: Tue Oct 29, 2019 10:26 am

7'' waveshare lcd hat

Post by tokanawa » Mon Dec 02, 2019 2:00 pm

Hi, I'm trying to connect this screen to stereopi with compute module 3, but all a got so far is black screen with backlit on.
Like this:
stereopi.jpg
stereopi.jpg (108.69 KiB) Viewed 31 times
Running on raspbian buster. I2C and SPI enabled and here's my config:

Code: Select all

[all]
dtoverlay=vc4-fkms-v3d
start_x=1
gpu_mem=128
dtoverlay=dpi24
enable_dpi_lcd=1
display_default_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x6f005
hdmi_cvt 1024 600 60 6 0 0 0
I also tried to follow this tutorial, but nothing really changed.
Any suggestion on what I am doing wrong?

User avatar
Realizator
Site Admin
Posts: 295
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: 7'' waveshare lcd hat

Post by Realizator » Mon Dec 02, 2019 2:23 pm

Hi Tokanawa,
I’ve looked into Waveshare Wiki for this screen.
The first thing I noticed in your config is that you’re trying to load both dpi24 and vc4-fkms-v3d overlays. It is not good idea, as they may give you hardware conflicts.

Second mention is that dpi24 overlay try to rearrange pins, and angry for resources: https://www.raspberrypi.org/documentati ... /README.md
It may affect on stereoscopic cameras support and conflict with our dt-blob.bin, so it is better to do some delicate pin arrangement analysis.

Also I’d like to ask, did you try to run this screen with a classic Raspberry Pi (ideally 3B or 3B+, as they have the same CPU as Compute Module 3/3+)?
Eugene a.k.a. Realizator

Post Reply