Saving photos to USB drive

SLP v2 RaspiOS image discussion
Post Reply
joedevivo
Posts: 8
Joined: Tue Oct 12, 2021 2:55 pm

Saving photos to USB drive

Post by joedevivo »

I'm so close. The only thing I can't do is take pictures :lol:

My compute module has eMMC storage, which is running the SLP2 image. I've got a thumb drive in the usb port, formatted to FAT32 but I can't seem to convince the StereoPi to write to it. Any suggestions?

User avatar
Realizator
Site Admin
Posts: 785
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Saving photos to USB drive

Post by Realizator »

Hi joedevivo,
A half of my StereoPis is equipped with eMMC. After the first boot, SLP2 formats all free space on eMMC to FAT32, and images and photos are saved in this partition by default. So it's fine to use eMMC for this. I use onboard file manager for downloading images and videos.

As for the USB drive recordings:
- which version of SLP2 you are using?
- did you choose USB drive as a place to save files?
- how your USB drive is formatted?
Eugene a.k.a. Realizator

joedevivo
Posts: 8
Joined: Tue Oct 12, 2021 2:55 pm

Re: Saving photos to USB drive

Post by joedevivo »

I'm on v0.11.19 with a FAT32 USB drive.

The interesting bit is that I did set Recording > Storage to "USB drive", but when I change it to "microSD", which I'm assuming is that eMMC partition you're talking about, it still won't save the file.

joedevivo
Posts: 8
Joined: Tue Oct 12, 2021 2:55 pm

Re: Saving photos to USB drive

Post by joedevivo »

Still haven't been able to figure this out. Is there any log file I can check? The only output I get is `failed` where the path to the photo should be in the UI.

User avatar
Realizator
Site Admin
Posts: 785
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Saving photos to USB drive

Post by Realizator »

Hi joedevivo,
Since our file system is read-only by default, we keep all logs for the current session here: /tmp/cams-data.log
Please note this is the temporary path and it is erased after reboot.
Eugene a.k.a. Realizator

joedevivo
Posts: 8
Joined: Tue Oct 12, 2021 2:55 pm

Re: Saving photos to USB drive

Post by joedevivo »

Here's my log file. I imagine the problem is down at the bottom with all that mmal stuff. Any ideas?

Code: Select all

console root$ cat /tmp/cams-data.log

Raspberri Pi / StereoPi camera client
Board model: Raspberry Pi Compute Module 4 Rev 1.0
Board supported
Loading camera config file... done
Using MJPEG client 192.168.1.66:0
Init frame buffer 60004836 bytes
Init frame buffer for transcoding 13004836 bytes
Raspivid thread started
Running: ../bin/raspivid -t 0  --stereo SBS -fs  -cs 0  -w 1280 -h 720  -fps 0  --flicker auto  --awb auto  --exposure auto  --bitrate 3000000  --opacity 255  --spstimings --inline --flush -o - 
Live stream video resolution changed to 1280x720
Clear frame shared memory
Clear frame shared memory
Camera shot
Terminated
Raspivid thread finished
Raspistill thread started
Shot filename: 2021-12-07_13-17-25.jpg
Preview filename: 2021-12-07_13-17-25-preview.jpg
raspistill -t 500 --nopreview --burst  --stereo SBS  -cs 0  -w 8112 -h 3040  --flicker auto  --awb auto  --exposure auto  -o /media/usb/DCIM/2021-12-07_13-17-25.jpg 
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

File /media/usb/DCIM/2021-12-07_13-17-25.jpg not found

Post Reply