Update/Upgrade OpenCV Raspbian Image Camera don't work

OpenCV, Python and other image processing questions
Post Reply
Kai
Posts: 1
Joined: Fri Sep 06, 2019 1:19 pm

Update/Upgrade OpenCV Raspbian Image Camera don't work

Post by Kai » Fri Sep 06, 2019 1:34 pm

Hi all,

I'm so happy that I received my new StereoPi - Deluxe Kit, I really love it.
I'm using the Raspbian Image from https://github.com/realizator/stereopi-tutorial.
Everthing works fine, until I update and upgrade the stereopi... after that nothing is working anymore.
Mirroring the image back again and is working.
So the update produces trouble.

User avatar
Realizator
Site Admin
Posts: 281
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Update/Upgrade OpenCV Raspbian Image Camera don't work

Post by Realizator » Fri Sep 06, 2019 2:08 pm

Hi Kai,
We prefer to use stable tested releases, that’s why our images are “conservative”.
But during next several days I will try to test new Raspbian and port our scripts there. If everything will work fine - I publish updated code and Raspbian image.
Eugene a.k.a. Realizator

User avatar
Realizator
Site Admin
Posts: 281
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Update/Upgrade OpenCV Raspbian Image Camera don't work

Post by Realizator » Tue Sep 10, 2019 7:24 am

Hi Kai,
I confirm that it is some bug in the latest Raspbian kernels. I've asked Raspberry Pi engineers about this issue.
Right now I'm trying to prepare stable OpenCV image with Raspbian Buster, and if everything is Ok, I'll be back with OpenCV installation guide and ready-to-use image.
Eugene a.k.a. Realizator

User avatar
Realizator
Site Admin
Posts: 281
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Update/Upgrade OpenCV Raspbian Image Camera don't work

Post by Realizator » Tue Sep 10, 2019 8:34 am

Ok, I've just published our guide for installing OpenCV 3.4.2 to Buster without breaking stereoscopic support:
https://github.com/realizator/stereopi- ... -notice.md
Eugene a.k.a. Realizator

User avatar
Realizator
Site Admin
Posts: 281
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Update/Upgrade OpenCV Raspbian Image Camera don't work

Post by Realizator » Wed Oct 09, 2019 5:58 am

Well, we got a comment on broken stereoscopic support from the Raspberry Pi developers. Looks like new AWB algorythm in the latest firmware is a problem. You can find details in this GitHub discussion: https://github.com/raspberrypi/firmware/issues/1253

<><><>UPDATE<><><>
To say briefly, you can use a temporary solution, proposed by RPi engineer 6by9, and BEFORE accessing camera run this code once:

Code: Select all

sudo vcdbg set awb_mode 0
This command will turn AWB algo to the previous revision, and stereoscopic mode will work fine. Please notice, this works untill reboot. You can add it to autostart.
So now you can do all you need including apt-get upgrade, and use this patch.
I hope this issue will be patched soon, and we'll be able to do Raspbian upgrade without any issues.
Eugene a.k.a. Realizator

Post Reply