Installation of .blob file on Ubuntu Server

OpenCV, Python and other image processing questions
Post Reply
thesoundman000
Posts: 1
Joined: Wed Mar 11, 2020 12:06 am

Installation of .blob file on Ubuntu Server

Post by thesoundman000 »

Hi, I'm needing a ubuntu installation for the project I'm working on currently and I'm unable to access the camera. I was hoping to follow the below but it hasn't worked out for me.

https://forum.stereopi.com/viewtopic.php?t=825

I'm using Ubuntu Server 18.04.4 for Raspberry Pi 3. the .blob file has been placed in /writable/boot AND /writable/boot/firmware/ (because in other matters the boot folder has been found to actually be there which I don't quite understand) but unfortunately there's been no luck. Is this the correct folder? megils parting comments are unfortunately ambiguous, I can't determine with certainty if I've installed the .blob in the correct location.

Are there also any further packages that will be necessary to use the camera? Being Ubuntu I can't (easily) install the raspi utils and it seems a bit pointless to install them simply for a test case unless of course they are necessary for the operation of everything.

User avatar
Realizator
Site Admin
Posts: 595
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Installation of .blob file on Ubuntu Server

Post by Realizator »

Hi thesoundman000,
I have no experience with Ubuntu on a Raspberry Pi.
My first suggestion is to check, if you're using 32bit edition. AFAIK, real 64bit support is not available for RPi now (at least for the camera utils), but 6by9 mentioned on RPi forums, that theoretically it can work, if you build it from sources.
We prefer to use native raspivid and raspicam applications instead of V4L, as they are working out of the box, and they are stable. You mentioned "I'm unable to access the camera". How do you try to access the camera(s)?

As for dt-blob.bin, you already found Megil's comment. You can try to put it in all places you suggest to work, in order to find correct place.

p.s. I also wrote an email to Megil, asking him to help with this issue. I hope my email will not drown in his spam folder...
p.p.s Well, my email to Megil was returned with "Domain is not accessible" message :-(
Eugene a.k.a. Realizator

megil
Posts: 12
Joined: Mon Dec 23, 2019 8:32 am

Re: Installation of .blob file on Ubuntu Server

Post by megil »

Insert the memory card into the computer.

You will see 2 partitions.

1 - Writable

2 - System boot

It is necessary to send the file named "dt-blob.bin" to the "system*boot" part. This is correct.


It didn't work because I had previously put the "dt-blob.bin" file into "/ writable / boot". This is wrong.

Post Reply