ROS depth map error

OpenCV, Python and other image processing questions
Post Reply
minar
Posts: 2
Joined: Thu Jun 06, 2019 6:15 am

ROS depth map error

Post by minar » Thu Jun 06, 2019 6:23 am

Hi
I am trying to get the example code on https://github.com/realizator/StereoPi- ... h-map-test running but with the current Ubiquity image (12-02-2019) I am getting an error, "Camera is not enabled." The camera interface is enabled via raspi-config.
Any ideas for help?

User avatar
Realizator
Site Admin
Posts: 194
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: ROS depth map error

Post by Realizator » Thu Jun 06, 2019 7:24 am

minar wrote:
Thu Jun 06, 2019 6:23 am
Hi
I am trying to get the example code on https://github.com/realizator/StereoPi- ... h-map-test running but with the current Ubiquity image (12-02-2019) I am getting an error, "Camera is not enabled." The camera interface is enabled via raspi-config.
Any ideas for help?
Hello Minar,
Please try to run "raspistill -cs 0", and after that "raspistill -cs 1" to check, if raspistill and camera subsystem works?
Eugene a.k.a. Realizator

minar
Posts: 2
Joined: Thu Jun 06, 2019 6:15 am

Re: ROS depth map error

Post by minar » Thu Jun 06, 2019 11:39 am

Hi Eugene

"raspistill -cs 0/1" failed as well and vcgencmd get_camera returned supported=0 detected=0

I found a solution though:
I copied the /boot/dt-blob.bin file from the stereopi image into the Ubiquity boot folder and that got it to work.

Also missing were ros-kinetic-stereo-image-proc and ros-kinetic-image-view.

Now it works - I branched on github. Thanks for the example!

User avatar
Realizator
Site Admin
Posts: 194
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: ROS depth map error

Post by Realizator » Thu Jun 06, 2019 12:32 pm

Great! I'm glad it works for you!
My next plans is to calibrate wide angle cameras for upcoming robot experiment. :)
Eugene a.k.a. Realizator

Post Reply