Dual camera with CM4 and CM4IO

Other hardware discussion
Post Reply
MarcelC
Posts: 2
Joined: Fri May 07, 2021 12:00 pm

Dual camera with CM4 and CM4IO

Post by MarcelC »

Hi all
I am French, please be indulgent with my mistakes in English ...
I look forward to the delivery of my "Stereopi V2" card.
In the meantime, I started testing with a CM4 module mounted on the "CM4IO" development board.
I spent a lot of time before arriving at a solution to simultaneously access the 2 cameras connected to CAM0 and CAM1(IMX219)!
I started by modifying the "dt-blob.dts" file without finding a solution. Only one camera was accessible at a time, impossible to activate both at the same time.

I think I identified the problem: it comes from the "CAM-GPIO" signal. This is common to the 2 cameras and controls the power supply to the cameras.
The "Raspistill -csX" command only activates this signal for one of the 2 cameras, which is abnormal.
The reason is that the Raspberry detects only one at startup. This shouldn't be the case with my "dt-blob.dts" file.

I then checked the I2C lines of the 2 cameras: they indeed contain the identification frames of the cameras: BUT ONLY ONE IS POWERED !!!

I tried to find information to drive the "CAM_GPIO" signal, without success.
I then used an electronic technician's solution (which I am ...): scraping a track and soldering a bridge! View the photo.

Now the 2 cameras are operational. View the photo

I hope my tests and observations will be of use to others ...
Attachments
dt_blob_cm4_dualCam.zip
My "dt-blob" file
(1.5 KiB) Downloaded 30 times
Screen copy with the 2 camera activ
Screen copy with the 2 camera activ
2021-05-07-144648_1920x1080_scrot.png (1.07 MiB) Viewed 746 times
Photo of the 2 hardware camera modifications
Photo of the 2 hardware camera modifications
Modif camera IMX219.jpg (1.51 MiB) Viewed 746 times

User avatar
Realizator
Site Admin
Posts: 701
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Dual camera with CM4 and CM4IO

Post by Realizator »

Hello MarcelC,
Well, the brutlal force usually works, but this is the brutal force :-)

You see, when pins are not assigned correctly, the system is not able to do a camera reset and other options needed for the appropriate function.
I attached our dt-blob.bin file. This is the latest version, compatible with both cm3 and cm4. After unarchiving, please rename the file to "dt-blob.bin"
You can decompile it and see what's inside. To say briefly, we used the "stock" pins assignment, which should work with CM4IO board too.
Attachments
cm3-cm4-dt-blob.bin.zip
(2.59 KiB) Downloaded 28 times
Eugene a.k.a. Realizator

MarcelC
Posts: 2
Joined: Fri May 07, 2021 12:00 pm

Re: Dual camera with CM4 and CM4IO

Post by MarcelC »

Hello Eugene

First of all, thank you for your help in solving my problem.
I just copied your "dt-blob.bin" file to my CM4 via the CM4IO board.
Unfortunately the result is the same: only one camera is recognized with the "vcgencmd get_camera" command! The response is "supported = 2 detected = 1.
So I will go back to my hardware solution, although as you say a software solution would have been elegant.

I will analyze your "dts" file in detail to better understand it.

Cordially

Marcel CREMMEL

Post Reply