V2 (IMX219) camera module and SLP UDP stream?

Raspberry Pi cameras (V1, V2, wide angle etc), HDMI capture modules etc.
Post Reply
mcesh
Posts: 2
Joined: Tue Feb 18, 2020 5:26 am

V2 (IMX219) camera module and SLP UDP stream?

Post by mcesh »

Hi, I'm new to the StereoPi and just testing it out on the bench. I've got the deluxe kit and have been able to get one and two simultaneous streams going from the included cameras using the SLP image via UDP to Ubuntu 16.04 using gstreamer. However, I have a couple raspberry pi v2 camera modules (IMX219 sensors) with wide-angle lenses that I want to test, but so far if I plug one in, I can't get any video, and if I try taking a still using the stereopi.local web interface, the image link is 404. Is there something I need to do to get them working? I haven't yet had a chance to connect the Pi to HDMI to see if they are working locally.

For reference the gstreamer command I'm using is

Code: Select all

gst-launch-1.0 -v udpsrc port=3000 buffer-size=300000 ! h264parse ! avdec_h264 ! autovideosink sync=false
Thank you!

User avatar
Realizator
Site Admin
Posts: 595
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: V2 (IMX219) camera module and SLP UDP stream?

Post by Realizator »

Hi mcesh,
If you have a couple of classic V2 cameras like these

Image

and install both instead of cameras from your Deluxe kit, they should work without any additional settings.

You mentioned "but so far if I plug one in". You need to connect them both. If you connect one V2 camera and one V1 camera, system will have a problem (as under the hoot Raspbian use different drivers for them).
If you connect the only one camera, you need to set "2D" mode in admin panel.

Am I right understand you, that you use a classic V2 cameras with wide-angle extension like this one?

Image


(you can read our article related to wide-angle V2 cameras here in our blog)
If yes - they should work out of the box too.

Another point - you can use a special edition of wide angle V2 cameras from Soho Enterprise, like these:

Image

In this case you need a special edition of dt-blob for these cameras to work.

And the last notice.
If you have access to admin panel, you can go to the web-based bash:

Image

(we described how to use it in this article)
So you can stop our scripts (/opt/StereoPi/stop.sh) and look, how system see your cameras, typing a command

Code: Select all

vcgencmd get_camera
This command will show you two numbers - "supported" and "detected" cameras. If your "detected" number is not 2 but 0, it means you need to check the connection. Please share your results here.
Eugene a.k.a. Realizator

mcesh
Posts: 2
Joined: Tue Feb 18, 2020 5:26 am

Re: V2 (IMX219) camera module and SLP UDP stream?

Post by mcesh »

I had multiple issues:
- I had only the single V2 camera connected but 3D selected.
- I connected a second V2 camera and set 3D, and it still didn’t work. I ran the commands in the console and found supported = 2 connected = 1. I then set it to 2D mode and checked swap camera, and got video! It turned out the first camera was bad, and replacing it allowed me to get 3D.

FWIW, I am using Blue Robotics cameras (now discontinued), that are a V2 module with wide angle lens installed.

Thank you for your help!

User avatar
Realizator
Site Admin
Posts: 595
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: V2 (IMX219) camera module and SLP UDP stream?

Post by Realizator »

Hi Mcesh,
I'm glad it works for you now!
By the way, what project you're planning to do with the StereoPi? ;)
Eugene a.k.a. Realizator

Post Reply