WiFi dongle not connecting to Windows mobile hotspot

StereoPi hardware discussion
Post Reply
dragon
Posts: 4
Joined: Mon Feb 17, 2020 1:32 pm

WiFi dongle not connecting to Windows mobile hotspot

Post by dragon »

I use WiFi dongle with RTL8188 chip. I can connect my stereopi on router, phone hotspot but cannot connect to my Windows mobile hotspot. Maybe you know what the problem is?

User avatar
Realizator
Site Admin
Posts: 594
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: WiFi dongle not connecting to Windows mobile hotspot

Post by Realizator »

Sorry, I have no Win mobile device to check this. Looks like you need to check regional settings on your Win mobile hot spot, and also security settings. As this dongle works with your router and phone hot spot, I think this dongle and current StereoPi settings are Ok.
Eugene a.k.a. Realizator

stereomaton
Posts: 181
Joined: Tue May 21, 2019 12:33 pm
Location: France

Re: WiFi dongle not connecting to Windows mobile hotspot

Post by stereomaton »

WiFi issues are always hard to debug.
Since your setup works with other beacons, I would first check the channels: depending in the regions, different channels are allowed and your phone might emit in a channel that your dongle do not scan. For the troll, Windows is known to be insecure by default and you can check if it (do not) use the WPA protocol.

Code: Select all

iwlist wlan0 scan | grep 'ESSID\|WPA\|Channel'
On my StereoPi (currently OpenCV image, but I guess that this tool is on SLP as well), the result looks like this:

Code: Select all

[email protected]:~ $ iwlist wlan0 scan | grep 'ESSID\|WPA\|Channel'
                    ESSID:"Home network"
                    Frequency:2.412 GHz (Channel 1)
                    IE: WPA Version 1
                    IE: IEEE 802.11i/WPA2 Version 1
                    ESSID:"Repeater beacon"
                    Frequency:2.437 GHz (Channel 6)
                    IE: IEEE 802.11i/WPA2 Version 1
Here two networks are seen:
- "Home network" on channel 1 using WPA1 and WPA2
- "Repeater beacon" on channel 6 using WPA2

My PC sees a third one on channel 112 [5GHz band]
Stereophotographer and hacker
Despite my quite active participation in the forum, I am not in the StereoPi team
StereoPi Standard Edition + CM3Lite module + a few cameras

Post Reply