SLP2 image not working. Any suggestions?

SLP v2 RaspiOS image discussion
Post Reply
Posts: 1
Joined: Sat Apr 01, 2023 1:55 pm

SLP2 image not working. Any suggestions?

Post by bwegge »


I hope you can help. I recently purchase stereopi, and bought a cm4 (CM4002000) separately. When trying to use the SLP2-0.8.19 image it boots, but shows the error message "the board requires a newer version" and that "start4x.elf is not compatible". This just runs in a loop.

I then tried simply copying the files from a buster image onto an sd-card holding slp2-0.8.1. Not sure what I was expecting. In this case the stereopi boots fine and shows the feed from both camera's, but there is no user interface. So no way to record anything as far as I can tell.

I also just tried with a standard Rasperry Buster image and add the dt-blob.bin as described on the site. The stereopi boots and seems to work as a normal rasperrypi. raspistill -cs 0 and raspistill -cs 1 do not show a preview. So something is missing, not unsurprisingly.

Any suggestions on how I get the slp image to work? I am new to raspberrypi, so it is likely that I am missing the blatantly obvious.

I have connected two HQ camera's.

Kind regards


Just a quick update. The issue resolved using the beta image :)

User avatar
Site Admin
Posts: 900
Joined: Tue Apr 16, 2019 9:23 am

Re: SLP2 image not working. Any suggestions?

Post by Realizator »

Hi bwegge,

Your issue looks similar to [url]this one[/url].

I'm trying to emulate this to reproduce this error.

Could you please run this command and share the result with us:

Code: Select all

cat /proc/cpuinfo
Eugene a.k.a. Realizator

Post Reply