New article published

Post Reply
User avatar
Realizator
Site Admin
Posts: 549
Joined: Tue Apr 16, 2019 9:23 am
Contact:

New article published

Post by Realizator »

OpenCV: comparing the speed of C++ and Python code on the Raspberry Pi for stereo vision

We're moving our blog from Medium to the stereopi.com If you find some bugs (images, broken links etc. - please, let us know).
Eugene a.k.a. Realizator

stereomaton
Posts: 164
Joined: Tue May 21, 2019 12:33 pm
Location: France

Re: New article published

Post by stereomaton »

Does a long time to load considered as a bug?
On my current connection (24Mbps down / 30ms ping to stereopi.com), it takes 39s on mobile phone before being able to start to read (4-5 seconds on PC). I have not read the article yet.
Stereophotographer and hacker
Despite my quite active participation in the forum, I am not in the StereoPi team
StereoPi Standard Edition + CM3Lite module + a few cameras

User avatar
Realizator
Site Admin
Posts: 549
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: New article published

Post by Realizator »

stereomaton wrote:
Wed Feb 05, 2020 7:55 pm
Does a long time to load considered as a bug?
On my current connection (24Mbps down / 30ms ping to stereopi.com), it takes 39s on mobile phone before being able to start to read (4-5 seconds on PC). I have not read the article yet.
Hmmm... I'll look at images size, as a lot of them are high-res. ANd also will look in JS load time. Thank you for your notice!
Eugene a.k.a. Realizator

User avatar
Realizator
Site Admin
Posts: 549
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: New article published

Post by Realizator »

Stereomaton, today I turned on Clowdflare CDN for our main domain. Hope this helps to load our pages more quickly. :-)
Eugene a.k.a. Realizator

stereomaton
Posts: 164
Joined: Tue May 21, 2019 12:33 pm
Location: France

Re: New article published

Post by stereomaton »

I just tested on good mobile connection (30Mbps) and it took 55s today. There must be something in the script of the blog. The problem is that partial content is not displayed so that we cannot start reading before the end of load.

Anyway, I already read it now. :-)
Stereophotographer and hacker
Despite my quite active participation in the forum, I am not in the StereoPi team
StereoPi Standard Edition + CM3Lite module + a few cameras

User avatar
Realizator
Site Admin
Posts: 549
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: New article published

Post by Realizator »

Stereomaton, I can not sleep while page load is so long :-)
I recognizwed this page has 15 youtube videos, and each of video downloads JS player separately. I will try to use another approach later, but now I turned off "Loading" overlay, so user can see even a partially downloaded content before all YouTube staff is loaded. Hope it will help a bit :-)
Eugene a.k.a. Realizator

stereomaton
Posts: 164
Joined: Tue May 21, 2019 12:33 pm
Location: France

Re: New article published

Post by stereomaton »

It looks better. The page is still long to load, but at least we can start to read it.

It looks like you can have a big gain by lazy loading the youtube iframes. I was not sure at first, but I found a way to block them and my loading time changed from 8s (or 16s depending on where I consider all finished) to 1.5s on my computer today. I cannot test the same thing on my mobile. The idea is to only display a thumbnail and replace it by the iframe on click. There surely exist already written scripts to do this.
Stereophotographer and hacker
Despite my quite active participation in the forum, I am not in the StereoPi team
StereoPi Standard Edition + CM3Lite module + a few cameras

Post Reply