Oculus Go Installation

S.L.P. image questions, stereoscopic video livestream and recording, stereoscopic photo capture etc.
Post Reply
neilpstevenson
Posts: 8
Joined: Tue May 19, 2020 4:51 pm

Oculus Go Installation

Post by neilpstevenson »

Hi, I'm trying to install the application onto an Oculus Go, but not sure what I'm doing wrong. I've downloaded the ZIP file onto my PC and then:

adb.exe install StereoPi.apk
error: no devices/emulators found
adb: error: connect failed: no devices/emulators found
- waiting for device -

How does it find the device?

Thanks.

User avatar
Realizator
Site Admin
Posts: 570
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Oculus Go Installation

Post by Realizator »

Hi neilpstevenson,
Looks like your Oculus Go is not detected by your Windows computer. Have you connected it by micro USB cable? If it is visible by Windows?
Eugene a.k.a. Realizator

neilpstevenson
Posts: 8
Joined: Tue May 19, 2020 4:51 pm

Re: Oculus Go Installation

Post by neilpstevenson »

I believe so, it's showing "VR-Headset" in the folder view, but I haven't installed any specific drivers - do I need to?

User avatar
Realizator
Site Admin
Posts: 570
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Oculus Go Installation

Post by Realizator »

As a rule yes. Here is the link: https://developer.oculus.com/downloads/ ... b-drivers/
upd> Before upload, you can check if adb is able to see youre device by command "adb devices"
Eugene a.k.a. Realizator

neilpstevenson
Posts: 8
Joined: Tue May 19, 2020 4:51 pm

Re: Oculus Go Installation

Post by neilpstevenson »

Hmmm.. no difference. I’ll have another go tomorrow.

neilpstevenson
Posts: 8
Joined: Tue May 19, 2020 4:51 pm

Re: Oculus Go Installation

Post by neilpstevenson »

Ok, so first you need to enable "Developer Mode" on the Oculus Go. See https://developer.oculus.com/documentat ... ?device=GO
a) Install the ADB USB driver on Windows
b) Open the Oculus App on your phone
c) Select Settings->Oculus Go<deviceid> and under More Settings toggle the Developer Mode slider. This will require you to register a developer organisation if you haven't already.
d) Register a new organisation name against your account
e) If registering a new organisation, go back to (b)
f) On success, this will trigger Windows to install new drivers - wait for this to complete.
g) On the Oculus Go headset, enter VR mode and then approve developer and data accesses to the system
At this point the adb install command succeeds.

neilpstevenson
Posts: 8
Joined: Tue May 19, 2020 4:51 pm

Re: Oculus Go Installation

Post by neilpstevenson »

For some reason, the expected Library->Unknown Sources menu did not appear. After researching, I did this from my PC:
adb shell monkey -p com.virt2real.stereopi 1
And the app started ok straight away. Then after quitting the Unknown Sources menu does appear with the stereopi app at the bottom.

However, when I restart, the image is all green. Have restarted both the Oculus and StereoPi, but not effect.
Any ideas?
Thanks, Neil.

User avatar
Realizator
Site Admin
Posts: 570
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Oculus Go Installation

Post by Realizator »

neilpstevenson, sorry for misleading you with the driver installation. I suggested you already passed all steps for the sideloading (like developer mode etc.), and have a problem at the last step only (adb upload).
As for the absence in "unknown sources" - looks like something changed in the latest Go firmware. Usually we have no such a problem.
As for the "green" image - sometimes this issue appears when application run once, then goes to the background, and run again.
Try to run application first, and after that the StereoPi.
Eugene a.k.a. Realizator

neilpstevenson
Posts: 8
Joined: Tue May 19, 2020 4:51 pm

Re: Oculus Go Installation

Post by neilpstevenson »

Oddly I get the green image if I “exit” the application and then restart it. If I then let the Oculus go to standby and then put it back on, it comes up running ok.

User avatar
Realizator
Site Admin
Posts: 570
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Oculus Go Installation

Post by Realizator »

As a rule "exiting" means going to background mode, and this is a buggy for used h264 decoder. Try to "kill" application and run again.
Eugene a.k.a. Realizator

neilpstevenson
Posts: 8
Joined: Tue May 19, 2020 4:51 pm

Re: Oculus Go Installation

Post by neilpstevenson »

I found a more recent version of the .apk file, posted in a discussion by @Gol (6 Oct 2019) and this resolved the green image issue. Any reason why this isn’t the version on the Wiki?

User avatar
Realizator
Site Admin
Posts: 570
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: Oculus Go Installation

Post by Realizator »

Good catch! I will compare the versions and upload the newest to the Wiki. Thank you!
UPD> File in the Wiki is updated.
Eugene a.k.a. Realizator

Post Reply