SLP2 discussion

S.L.P. image questions, stereoscopic video livestream and recording, stereoscopic photo capture etc.
Post Reply
User avatar
Realizator
Site Admin
Posts: 693
Joined: Tue Apr 16, 2019 9:23 am
Contact:

SLP2 discussion

Post by Realizator »

SLP2 (or StereoPi Livestream Playground v2) is a specially cooked Raspberry OS, designed for the stereoscopic video live stream and recording, and for the stereoscopic photo experiments. You can take a look at some features in this brief video on YouTube.

Here is the early testers access:

1. SLP 2 image file (800Mb).

2. Update (please install!). Update file 0.8.9 (11 Mb)
To install the update, go to the "System" tab in the "Device settings" and upload this file. Or just put it to the BOOT partition manually.

3. Config file (cosmostreamer.conf) example is attached.
Key notes:
Ethernet access does not require any settings
Default WiFi settings (AP mode) are done for the CM4 or Pi4 (rows 35-43 in the attached file)
For external WiFi configuration (client mode):
- turn off AP mode, i.e. change row 37 "ap_iface=int" to "ap_iface="
- row 67 - change "wifi_iface=" to "wifi_iface=ext"
- rows 70 and 73 - put your WiFi name and password

Note: like with the SLP 1, this image is a simplified version of our Cosmostreamer solution. So don't be confused if you find both StereoPi and Cosmostreamer names in the code. :-)

Known issues (to be fixed):
1. Default video bitrate at the first start is 3Kbit/sec. Manually change it to 3000000 to fix.
2. The following image effects are not working correctly in the stereoscopic mode (Raspberry OS issue):
pasterise
pastel
gpen
hatch
emboss
negative
They will be removed from the video effects list.
Attachments
cosmostreamer.conf.zip
(1.84 KiB) Downloaded 20 times
Eugene a.k.a. Realizator

zoldaten
Posts: 44
Joined: Fri Apr 26, 2019 7:07 am

Re: SLP2 discussion

Post by zoldaten »

hi!

I use SLP with stereopi v.1 loads from eMMC.
Can i use boot from SD-card with SLP v.2 just for try ? Or i should overwrite it first on eMMC ?

User avatar
Realizator
Site Admin
Posts: 693
Joined: Tue Apr 16, 2019 9:23 am
Contact:

Re: SLP2 discussion

Post by Realizator »

Hi Zoldaten,
If your CM3 is equipped with the eMMC, you can't use the micro SD. So please upload it to eMMC.
Eugene a.k.a. Realizator

zoldaten
Posts: 44
Joined: Fri Apr 26, 2019 7:07 am

Re: SLP2 discussion

Post by zoldaten »

hi!

I`ve uploaded to CM3 stereopi SLP2 but have blank screen with only GUI-
2021-04-14_22h18_14.jpg
2021-04-14_22h18_14.jpg (10.23 KiB) Viewed 232 times
I ckecked cameras presented and server working connected by SSH to stereopi -
2021-04-14_22h21_03.jpg
2021-04-14_22h21_03.jpg (27.26 KiB) Viewed 232 times
And i couldn`t start up AP ( May be something here should be done -
2021-04-14_22h23_19.jpg
2021-04-14_22h23_19.jpg (9.94 KiB) Viewed 232 times
Where to find what means what ?

Thanks for patience.

zoldaten
Posts: 44
Joined: Fri Apr 26, 2019 7:07 am

Re: SLP2 discussion

Post by zoldaten »

ok. got it working. just needed to set up camera settings in options menu.

kuehfuss
Posts: 4
Joined: Thu Feb 04, 2021 9:35 am

Re: SLP2 discussion

Post by kuehfuss »

Dear Realizator,
i´m struggling to get the SLP 2 working on my steropi 1 with Rpi module 3. Everything seems to work but the preview in the browser does not refresh (its just a solid picture from the first load of the page). Also the recording does not work. It shows that it is recording when i press the red button but there is no file after stopping it.

kuehfuss
Posts: 4
Joined: Thu Feb 04, 2021 9:35 am

Re: SLP2 discussion

Post by kuehfuss »

I figured out that the function of the browser preview depends on the resolution witch I chose in the camera settings for video. Everything upon 720p stops the preview. Nevertheless the recording doesn´t work for me, regardless of resolution, bitrate or other camera settings.

Post Reply